Linux Mint and Yubikey PIV-Tool dependency

Just a quick one to give it some Google juice.

I recently switched to Linux Mint. A few weeks later it became time to change the PIN on my Yubikey. I added the Yubico apt repository and installed the yubikey-piv-manager as per the instructions here. Alas, it did not recognize my Yubikey and instead didsplayed the error:

“No Yubikey found. please insert a PIV enabled Yubikey…”

It was a bit of a mystery because dmesg output clearly showed the Yubi being inserted, so I knew the OS could see it.

Turns out you also need to install the opensc package to enable smart card support in Linux Mint. It doesn’t come installed nor does the Yubi repository include it as a dependency.